TLS umjesto SSL

Oct 27, 2015 at 1:32 PM
Edited Oct 27, 2015 at 1:33 PM
Oct 28, 2015 at 1:55 PM
Sadašnji server je ssl/tls, odakle bi ja znao kako je veza uspostavljena?
Postoji li neki server za testiranje sa samo tls vezom??
Oct 28, 2015 at 2:21 PM
btw. kod posta sa synacode mogu fixirat ssltype
// HTTP.Sock.SSL.SSLType:=LT_all;
// HTTP.Sock.SSL.SSLType:=LT_SSLv2;
// HTTP.Sock.SSL.SSLType:=LT_SSLv3;
// HTTP.Sock.SSL.SSLType:=LT_TLSv1;
// HTTP.Sock.SSL.SSLType:=LT_TLSv1_1;
// HTTP.Sock.SSL.SSLType:=LT_SSHv2;

prolaze mi echo sa LT_SSLv3 i LT_TLSv1
a LT_TLSv1_1 (iliti TLS v1.1) ne prolazi, iako na vijesti stoji da su podržani v1.1 i v1.2 (za 1.0 ne piše ništa)
U skladu s navedenim obavještavamo vas da sustav fiskalizacije podržava sigurnosni protokol TLS (v1.1 i v1.2) u testnoj i produkcijskoj okolini...
Oct 29, 2015 at 8:10 AM
Da li tu treba šta mijenjati onda što se tiće raverusovog riješenja?
Coordinator
Oct 29, 2015 at 8:12 AM
Mi pazimo na to, pravovremeno ćemo reagirati :)
Oct 29, 2015 at 8:21 AM
:) Hvala
Oct 29, 2015 at 8:27 AM
Hvala :-) i od mene
Coordinator
Nov 19, 2015 at 8:36 AM
Otvorili smo novu temu gdje možete pratiti sve što se tiče ovog problema:

https://fiskalizacija.codeplex.com/discussions/647821
Marked as answer by dkustec on 11/19/2015 at 12:43 AM
Nov 26, 2015 at 10:33 AM
Da ne spamam raverusovu temu sa dephi problemima, tu ću nastavit priču...
pa kaže:
LT_TLSv1_1 opće nije podržan od strane synacode 4.0 (iako ima na spisku LT_TLSv1_1)

TSSLType = ( LT_all, LT_SSLv2, LT_SSLv3, LT_TLSv1, LT_TLSv1_1, LT_SSHv2 );

kod pozivanja init funkcije ssl ctx pointer ostaje nil

....
Fctx := nil;
case FSSLType of
LT_SSLv2:
  Fctx := SslCtxNew(SslMethodV2);
LT_SSLv3:
  Fctx := SslCtxNew(SslMethodV3);
LT_TLSv1:
  Fctx := SslCtxNew(SslMethodTLSV1);
LT_all:        
  Fctx := SslCtxNew(SslMethodV23);
else
Exit;
end;

doda sam:
LT_TLSv1_1:
  Fctx := SslCtxNew(SslMethodTLSV1_1);
i inportira TLSv1_1_method iz ssleay32.dll verzija 1.0 (verzija 0.9.8.11 nema TLSv1_1_method)

nakon toga komunikacija radi (echo na xp i win10) pomoću chipera koji koristi TLSv1_1_method.
u OpenSSL dokumentaciji piše:
A client will send out TLSv1.1 client hello messages and will indicate that it only understands TLSv1.1

Šta bi značilo da smo serveru rekli da samo razumimo protokol TLSv1.1 i server bi trebao korisiti taj protokol za komunikaciju?? valjda??

Zna li neko možda neki demo server koji sigurno podržava samo TLSv1.1 i/ili TLSv1.2 (slovenci podržavaju i tls1.0 pa ništa od toga)?
Nov 27, 2015 at 11:21 AM
Znači na xp-u ti radi sa TLS1.1?
Dec 1, 2015 at 12:51 PM
Da, ako je virovat uputama iz OpenSSL dokumentacije. Zato i tražim TSL1.1/1.2 server da provjerim.