Sending works with Test Cert, not with official cert

Apr 2, 2013 at 2:50 PM
Edited Apr 2, 2013 at 2:54 PM

We are testing an update of our POS program for the Croatian market and have come across a problem.

We were provided with a test certificate and a test server and using this configuration we were able to connect to the Fisk server and received back a JIR.

We have now been given a real certificate and using this certificate connection to the server fails with a 500 error. No further details are forthcoming from the server or from the Fisk themselves.

Comparing the two certificates, test and real, all important information seems to be present and identical but obviously we must be overlooking something. Two differences we have noticed are the presnce of a Friendly Name in the real certificate which was absent in the test cert and the name of the supplier of the cert has changed from DEMO to RDC.

Edited to add teh file extension of the official cert is .P12 compard to .PFX in the test cert.
The test also succeeds with the test cert in the test application from Fisk
but fails with the official cert in this test application.

Can anyone help?

Apr 2, 2013 at 2:54 PM
Hi, for production environment you have to use production CIS URL. Also, in the production env. you must provide a valid root certificate, which can be obtained here
Apr 2, 2013 at 3:09 PM
Thanks for the quick reply.

The URL for CSI we're using in the production environment is: and
the linked certificate is installed in the Trusted Root Certificates folder.

The returned error is still the same

02/04/2013 16:09:13 : Connection to the CIS service OK
02/04/2013 16:09:13 : Bills processing (Step 1) OK
02/04/2013 16:09:13 : Start Bill processing (step 2)
02/04/2013 16:09:13 : >Sending Business Premise
02/04/2013 16:09:16 : The remote server returned an error: (500) Internal Server Error. Error during Business Premise upload
02/04/2013 16:09:16 : Bill Update num 849258124 with ERROR_sERR
Apr 2, 2013 at 3:18 PM
Edited Apr 2, 2013 at 3:40 PM
Install RDCca cerr on POS

Sent from my iPhone
Apr 2, 2013 at 3:27 PM
Thanks. Where can I download RFCca.cer?
Apr 2, 2013 at 3:39 PM

RDCca cert
Apr 2, 2013 at 4:57 PM
Is OIB correct?
Apr 3, 2013 at 10:29 AM
Problem solved - for some reason the XML is using two separate variables for the same URL (and the test URL is hard-coded in the XML several times) so although we had updated our config file to send the new URL it was only applying to one variable and thus was not sending correctly.